Publishing Applications with Citrix XenApp 6.5


This is the fourth post in the Installing and Configuring Citrix XenApp 6.5 Series:

  1. Install and Configure Citrix XenApp Licensing
  2. Install and Configure Citrix XenApp 6.5
  3. Configure Web Interface for Citrix XenApp 6.5
  4. Publishing Applications with Citrix XenApp 6.5 (this post)
  5. Install and Configure Profile Management for Citrix XenApp 6.5
  6. Add Servers to a XenApp 6.5 Farm
  7. Configure Pass-through Authentication for Citrix XenApp 6.5
  8. Install and Configure Citrix Secure Gateway


This post contains the following sections:

[Read more…]

Custom settings are not saved in the User Profile when using Citrix XenApp


A quick fix for many issues with Citrix XenApp involves deleting (read: moving) the User Profile, and creating a new one by logging in again.

However, sometimes this creates another problem where custom settings are not saved between sessions, eg. SQL Server Management Studio will always display the “configuring the environment for first time use” message, and view options revert to default, every time you log in.


  1. Make sure you delete User Profiles correctly via Advanced system settings (DO NOT just delete from C:\Users):Delete-User-Profiles
  2. If there are still issues, check for and delete profiles ending with .bak in the registry (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList):
  3. Next time the user logs in, they shouldn’t get the “You have been logged on with a temporary profile” warnings, and custom settings should persist between sessions.

Windows cannot locate the server copy of your roaming profile and is attempting to log you on with your local profile


Several users were recently getting the following error when logging into one of our Terminal Servers:

Windows cannot locate the server copy of your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you logoff.


Go into the Group Policy Editor on the Terminal Server (gpedit.msc) Computer Config > Admin Templates > System > User Profiles > Only Allow Local Profile – Enable.

Cannot see RemoteApp icons for users – only administrators


You’ve installed and configured Remote Desktop Services (RDS) on a 2008 R2 server, and configured several RemoteApp Programs to display via RD Web Access.

Despite adding your user account to the Remote Desktop Users local group, and your computer account to the TS Web Access Computers local group, the RemoteApp icons do not display when logged into RD Web Access (https://hostname/RDWeb). However, the icons appear fine when logging in as Administrator.

Here’s how I fixed it:

[Read more…]